summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorAlan Coopersmith <alan.coopersmith@sun.com>2009-10-13 16:42:47 -0700
committerAlan Coopersmith <alan.coopersmith@sun.com>2009-10-13 16:42:47 -0700
commit76cdfffcc170a5000c383f05fd6af0ccc0cb812b (patch)
treec7851164e2e5f6c52c266c39db6cae5411b3db1c /configure.ac
parent544ebd780137a61ba15b1f33c920b353aae3150d (diff)
Migrate to xorg macros 1.3 & XORG_DEFAULT_OPTIONS
Signed-off-by: Alan Coopersmith <alan.coopersmith@sun.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac14
1 files changed, 5 insertions, 9 deletions
diff --git a/configure.ac b/configure.ac
index dd51d09..28450e8 100644
--- a/configure.ac
+++ b/configure.ac
@@ -26,25 +26,21 @@ AC_INIT(xgamma,[1.0.2], [https://bugs.freedesktop.org/enter_bug.cgi?product=xorg
AM_INIT_AUTOMAKE([dist-bzip2])
AM_MAINTAINER_MODE
-# Require xorg-macros: XORG_CWARNFLAGS, XORG_CHANGELOG
-m4_ifndef([XORG_MACROS_VERSION], [AC_FATAL([must install xorg-macros 1.2 or later before running autoconf/autogen])])
-XORG_MACROS_VERSION(1.2)
+# Require xorg-macros 1.3 or later: XORG_DEFAULT_OPTIONS
+m4_ifndef([XORG_MACROS_VERSION],
+ [m4_fatal([must install xorg-macros 1.3 or later before running autoconf/autogen])])
+XORG_MACROS_VERSION(1.3)
AM_CONFIG_HEADER(config.h)
AC_PROG_CC
AC_PROG_INSTALL
-XORG_CWARNFLAGS
+XORG_DEFAULT_OPTIONS
# Checks for pkg-config packages
PKG_CHECK_MODULES(XGAMMA, x11 xxf86vm)
-XGAMMA_CFLAGS="$CWARNFLAGS $XGAMMA_CFLAGS"
AC_SUBST(XGAMMA_CFLAGS)
AC_SUBST(XGAMMA_LIBS)
-XORG_MANPAGE_SECTIONS
-XORG_RELEASE_VERSION
-XORG_CHANGELOG
-
AC_OUTPUT([Makefile])