summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorAlan Coopersmith <alan.coopersmith@oracle.com>2024-02-15 16:52:22 -0800
committerAlan Coopersmith <alan.coopersmith@oracle.com>2024-02-15 16:52:22 -0800
commita239d6fa04a35be84720a4516e8164dc634bb3d3 (patch)
tree84057e162f19c1ceaa3d3a59dd5fa38d54e7858d /configure.ac
parentbf82e932006e05543e24af49702193a9d8678bfb (diff)
Use autoconf instead of platform ifdefs to check for lrand48()
Signed-off-by: Alan Coopersmith <alan.coopersmith@oracle.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac3
1 files changed, 3 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 1421791..d0deee7 100644
--- a/configure.ac
+++ b/configure.ac
@@ -53,6 +53,9 @@ AC_ARG_WITH(appdefaultdir,
[appdefaultdir="$withval"], [appdefaultdir="${xt_appdefaultdir}"])
AC_SUBST(appdefaultdir)
+# Checks for library functions.
+AC_CHECK_FUNCS([lrand48])
+
AC_CONFIG_FILES([
Makefile
man/Makefile])