summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorGaetan Nadon <memsize@videotron.ca>2010-07-18 09:38:40 -0400
committerGaetan Nadon <memsize@videotron.ca>2010-07-18 09:38:40 -0400
commitebd3e2400d05f779c0be6f1db352fe0e55a2c435 (patch)
treeadf89c92bd51c9a7332660888d0bd672d5009eda /configure.ac
parent79eee2354907010045d64c05b3a008cffda2c952 (diff)
config: allow to build tarball when yacc is missingmaster
Autoconf does not handle this scenario as well as Automake does. If gram.c is already there, do not abort the configuration if yacc is missing as it is not needed. If both xkbparse.c and yacc are missing, abort configuration. Yacc is a required tool to build the package. Signed-off-by: Gaetan Nadon <memsize@videotron.ca>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac3
1 files changed, 2 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 949aeba..d1035d8 100644
--- a/configure.ac
+++ b/configure.ac
@@ -36,7 +36,8 @@ XORG_DEFAULT_OPTIONS
AC_PROG_LEX
AC_PROG_YACC
AC_PATH_PROG([YACC_INST], $YACC)
-test -z "$YACC_INST" && AC_MSG_ERROR([yacc not found - unable to compile gram.y])
+AC_CHECK_FILE([$srcdir/gram.c], [],
+ [test -z "$YACC_INST" && AC_MSG_ERROR([yacc not found - unable to compile gram.y])])
AC_PROG_CC
AC_PROG_INSTALL