summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorGaetan Nadon <memsize@videotron.ca>2011-06-17 13:39:27 -0400
committerGaetan Nadon <memsize@videotron.ca>2011-06-18 14:33:28 -0400
commit120a58116f2e3a223dbb78e0b33d3755eeb8ad5a (patch)
treeb173b412b4b154ff3acfbe9fad8e7e20c8324144 /Makefile.am
parenta81fab654085239ffcc4981b6bdab9fc18ec3d08 (diff)
Move man pages in the man directory
Now that the cpp tool is no longer needed, normalize the man pages build. Reviewed-by: Alan Coopersmith <alan.coopersmith@oracle.com> Signed-off-by: Gaetan Nadon <memsize@videotron.ca>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am26
1 files changed, 5 insertions, 21 deletions
diff --git a/Makefile.am b/Makefile.am
index 6c4ef24..c179fa9 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -29,25 +29,8 @@ xinit_LDADD = $(XINIT_LIBS)
xinit_SOURCES = \
xinit.c
-appmandir = $(APP_MAN_DIR)
-appman_PRE = startx.man xinit.man
-appman_DATA = $(appman_PRE:man=$(APP_MAN_SUFFIX))
-
-# String replacements in MAN_SUBSTS now come from xorg-macros.m4 via configure
-MAN_SUBSTS+= -e 's|__XSERVERNAME__|$(XSERVERNAME)|g' \
- -e 's|__XCONFIGFILE__|$(XCONFIGFILE)|g' \
- -e 's|__XCONFIGFILEMAN__|$(XCONFIGFILEMAN)|g' \
- -e 's|__xinitdir__|$(XINITDIR)|g' \
- -e 's|__bindir__|$(bindir)|g' \
- -e 's|__libdir__|$(libdir)|g' \
- -e 's|__SCOMAN__|$(SCOMAN)|g'
-
include $(top_srcdir)/cpprules.in
-SUFFIXES += .$(APP_MAN_SUFFIX) .man
-.man.$(APP_MAN_SUFFIX):
- $(AM_V_GEN)$(SED) $(MAN_SUBSTS) < $< > $@
-
xinitrcdir = $(XINITDIR)
PROGCPPDEFS = \
@@ -67,18 +50,19 @@ CPP_FILES_FLAGS = \
-D__bindir__="$(bindir)" \
-DBUNDLE_ID_PREFIX="$(bundleidprefix)"
+SUBDIRS = man
if LAUNCHD
-SUBDIRS = launchd
+SUBDIRS += launchd
endif
-DIST_SUBDIRS = launchd
+DIST_SUBDIRS = launchd man
xinitrc_DATA = xinitrc
MAINTAINERCLEANFILES = ChangeLog INSTALL
-CLEANFILES = xinitrc startx $(appman_DATA) $(launchagents_DATA)
+CLEANFILES = xinitrc startx $(launchagents_DATA)
-EXTRA_DIST = xinitrc.cpp startx.cpp $(appman_PRE) \
+EXTRA_DIST = xinitrc.cpp startx.cpp \
autogen.sh
.PHONY: ChangeLog INSTALL