summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorMatthieu Herrb <matthieu@bluenote.herrb.com>2007-09-15 18:11:58 +0200
committerMatthieu Herrb <matthieu@bluenote.herrb.net>2008-03-08 18:48:16 +0100
commit990ed1483e9829a4977cbc52f631281f425aa5e0 (patch)
tree41af1e738ace61b473dda7209a9fc5b7e558a407 /configure.ac
parent26c69943680c943b879380a999cf01acec45fc2d (diff)
Add configure options to specify the default window manager and applications
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac16
1 files changed, 15 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 0d13f8d..82e9dbf 100644
--- a/configure.ac
+++ b/configure.ac
@@ -51,6 +51,8 @@ DEFAULT_XTERM=xterm
DEFAULT_XSERVER=${bindir}/X
DEFAULT_XAUTH=xauth
DEFAULT_XINIT=xinit
+DEFAULT_WM=fvwm
+DEFAULT_XCONSOLE=xconsole
AC_ARG_WITH(xrdb,
AS_HELP_STRING([--with-xrdb=XRDB], [Path to xrdb]),
@@ -125,6 +127,16 @@ fi
AC_SUBST([launchagentsdir])
AM_CONDITIONAL(LAUNCHD, [test "x$LAUNCHD" = "xyes"])
+AC_ARG_WITH(wm,
+ AS_HELP_STRING([--with-wm=WM], [Path to default window manager]),
+ [WM="$withval"],
+ [WM="$DEFAULT_WM"])
+
+AC_ARG_WITH(xconsole,
+ AS_HELP_STRING([--with-xconsole=XCONSOLE], [Path to xconsole]),
+ [XCONSOLE="$withval"],
+ [XCONSOLE="$DEFAULT_XCONSOLE"])
+
# Checks for pkg-config packages
PKG_CHECK_MODULES(XINIT, x11)
@@ -142,7 +154,7 @@ AC_PATH_PROGS(MCOOKIE, [mcookie], [$MCOOKIE],
case $host_os in
*openbsd*)
- MCOOKIE='dd if=/dev/arandom bs=16 count=1 2>/dev/null | hexdump -e \\\"%08x\\\"'
+ MCOOKIE='dd if=/dev/urandom bs=16 count=1 2>/dev/null | hexdump -e \\\"%08x\\\"'
;;
esac
@@ -173,6 +185,8 @@ AC_SUBST(XTERM)
AC_SUBST(XSERVER)
AC_SUBST(XAUTH)
AC_SUBST(XINIT)
+AC_SUBST(WM)
+AC_SUBST(XCONSOLE)
# Defines which X servers are listed in help output in xinit.c
# Cheat, lie, and assume all the world is Xorg for now