summaryrefslogtreecommitdiff
path: root/launchd/user_startx/Makefile.am
diff options
context:
space:
mode:
authorJeremy Huddleston <jeremyhu@apple.com>2011-04-25 23:09:03 -0700
committerJeremy Huddleston <jeremyhu@apple.com>2011-04-26 12:54:46 -0700
commit5f5390886004f785b4338fcff27f287c9aa6cd8c (patch)
tree48147a155ec27823c63027b0a551e7b9304459a9 /launchd/user_startx/Makefile.am
parentc6a7f895c8c90b85ed4fd08927c47b0d17ed067a (diff)
launchd: Enable stdout/stderr redirection to ASL
Don't rely on launchd to do our logging for us. Signed-off-by: Jeremy Huddleston <jeremyhu@apple.com> Reviewed-by: Daniel A. Steffen <dsteffen@apple.com>
Diffstat (limited to 'launchd/user_startx/Makefile.am')
-rw-r--r--launchd/user_startx/Makefile.am12
1 files changed, 9 insertions, 3 deletions
diff --git a/launchd/user_startx/Makefile.am b/launchd/user_startx/Makefile.am
index 600d325..30270dd 100644
--- a/launchd/user_startx/Makefile.am
+++ b/launchd/user_startx/Makefile.am
@@ -23,10 +23,16 @@ include $(top_srcdir)/cpprules.in
xinitrcdir = $(XINITDIR)
+xinitrc_PROGRAMS = launchd_startx
+
+AM_CPPFLAGS = -DXINITDIR=\"$(xinitrcdir)\" -DBINDIR=\"$(bindir)\" -DLAUNCHD_ID_PREFIX=\"$(launchdidprefix)\"
+
+dist_launchd_startx_SOURCES = \
+ ../console_redirect.c \
+ launchd_startx.c
+
CPP_FILES_FLAGS = \
- -DXINITDIR=$(XINITDIR) $(PROGCPPDEFS) -DLIBDIR=$(libdir) \
- -DSHELL_CMD=$(SHELL_CMD) $(STARTX_COOKIE_FLAGS) \
- -D__libexecdir__="$(libexecdir)" \
+ -D__xinitrcdir__="$(xinitrcdir)" \
-D__bindir__="$(bindir)" \
-DLAUNCHD_ID_PREFIX="$(launchdidprefix)"