summaryrefslogtreecommitdiff
path: root/man/Makefile.am
diff options
context:
space:
mode:
authorGaetan Nadon <memsize@videotron.ca>2011-06-17 13:39:27 -0400
committerGaetan Nadon <memsize@videotron.ca>2011-06-18 14:33:28 -0400
commit120a58116f2e3a223dbb78e0b33d3755eeb8ad5a (patch)
treeb173b412b4b154ff3acfbe9fad8e7e20c8324144 /man/Makefile.am
parenta81fab654085239ffcc4981b6bdab9fc18ec3d08 (diff)
Move man pages in the man directory
Now that the cpp tool is no longer needed, normalize the man pages build. Reviewed-by: Alan Coopersmith <alan.coopersmith@oracle.com> Signed-off-by: Gaetan Nadon <memsize@videotron.ca>
Diffstat (limited to 'man/Makefile.am')
-rw-r--r--man/Makefile.am20
1 files changed, 20 insertions, 0 deletions
diff --git a/man/Makefile.am b/man/Makefile.am
new file mode 100644
index 0000000..074bc36
--- /dev/null
+++ b/man/Makefile.am
@@ -0,0 +1,20 @@
+
+appmandir = $(APP_MAN_DIR)
+appman_PRE = startx.man xinit.man
+appman_DATA = $(appman_PRE:man=$(APP_MAN_SUFFIX))
+
+EXTRA_DIST = $(appman_PRE)
+CLEANFILES = $(appman_DATA)
+SUFFIXES = .$(APP_MAN_SUFFIX) .man
+
+MAN_SUBSTS+= -e 's|__XSERVERNAME__|$(XSERVERNAME)|g' \
+ -e 's|__XCONFIGFILE__|$(XCONFIGFILE)|g' \
+ -e 's|__XCONFIGFILEMAN__|$(XCONFIGFILEMAN)|g' \
+ -e 's|__xinitdir__|$(XINITDIR)|g' \
+ -e 's|__bindir__|$(bindir)|g' \
+ -e 's|__libdir__|$(libdir)|g' \
+ -e 's|__SCOMAN__|$(SCOMAN)|g'
+
+# String replacements in MAN_SUBSTS now come from xorg-macros.m4 via configure
+.man.$(APP_MAN_SUFFIX):
+ $(AM_V_GEN)$(SED) $(MAN_SUBSTS) < $< > $@