summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac17
1 files changed, 7 insertions, 10 deletions
diff --git a/configure.ac b/configure.ac
index 42c3b60..6f6bf6c 100644
--- a/configure.ac
+++ b/configure.ac
@@ -102,22 +102,19 @@ AC_ARG_WITH(launchdaemons-dir, AS_HELP_STRING([--with-launchdaemons-dir=PATH],
if test "x$LAUNCHD" = "xauto"; then
unset LAUNCHD
- AC_CHECK_PROG(LAUNCHD, [launchd], [yes], [no])
-fi
-
-if test "x$LAUNCHD" = "xyes" ; then
- AC_DEFINE(HAVE_LAUNCHD, 1, [launchd support available])
-
case $host_os in
- darwin9*|darwin1*)
- AM_CONDITIONAL(APPLE_LEOPARD, true)
+ darwin8*)
+ LAUNCHD=no
;;
*)
- AM_CONDITIONAL(APPLE_LEOPARD, false)
+ AC_CHECK_PROG(LAUNCHD, [launchd], [yes], [no])
;;
esac
+fi
+
+if test "x$LAUNCHD" = "xyes" ; then
+ AC_DEFINE(HAVE_LAUNCHD, 1, [launchd support available])
else
- AM_CONDITIONAL(APPLE_LEOPARD,false)
launchagentsdir=""
launchdaemonsdir=""
fi