summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorAlan Coopersmith <alan.coopersmith@oracle.com>2010-09-23 20:29:57 -0700
committerAlan Coopersmith <alan.coopersmith@oracle.com>2010-09-23 20:29:57 -0700
commit87576c9ebf0f28d66833bb28a8199df1aa01f693 (patch)
tree9c30784fe4f23be3a5ad0c2d374488fe3d619e42 /configure.ac
parentd083293a4e227e9dd27f74cde391fde4c5824b0c (diff)
config: Remove unnecessary calls from configure.ac
AC_PROG_CC & AC_PROG_INSTALL are provided by XORG_DEFAULT_OPTIONS now PKG_CONFIG_MODULES handles AC_SUBST of the CFLAGS & LIBS variables Signed-off-by: Alan Coopersmith <alan.coopersmith@oracle.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 0 insertions, 4 deletions
diff --git a/configure.ac b/configure.ac
index 8cfb5cd..2991a5f 100644
--- a/configure.ac
+++ b/configure.ac
@@ -33,20 +33,16 @@ XORG_DEFAULT_OPTIONS
AM_CONFIG_HEADER(config.h)
-AC_PROG_CC
AC_PROG_YACC
AC_PATH_PROG([YACC_INST], $YACC)
AC_CHECK_FILE([$srcdir/xkbparse.c], [],
[test -z "$YACC_INST" && AC_MSG_ERROR([yacc not found - unable to compile xkbparse.y])])
-AC_PROG_INSTALL
AC_CHECK_FUNCS([strdup strcasecmp])
# Checks for pkg-config packages
PKG_CHECK_MODULES(XKBCOMP, x11 xkbfile)
-AC_SUBST(XKBCOMP_CFLAGS)
-AC_SUBST(XKBCOMP_LIBS)
AC_ARG_WITH([xkb_config_root],
[AC_HELP_STRING([--with-xkb-config-root=<paths>],