summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorAlan Coopersmith <alan.coopersmith@oracle.com>2024-01-17 09:26:40 -0800
committerAlan Coopersmith <alan.coopersmith@oracle.com>2024-01-17 09:26:40 -0800
commit71d8e89f43de90571ed7e7486035f56190f10888 (patch)
treeb6b699c6ac7638617558d04102fa22ab31297bfa /configure.ac
parent2b9d8f5bac5d2352f8021548b4852014ed683b2c (diff)
Use reallocarray() if available
Signed-off-by: Alan Coopersmith <alan.coopersmith@oracle.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac7
1 files changed, 7 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index f70eab3..a7660c4 100644
--- a/configure.ac
+++ b/configure.ac
@@ -27,6 +27,7 @@ AC_INIT(xlsfonts, [1.0.7],
[https://gitlab.freedesktop.org/xorg/app/xlsfonts/issues],xlsfonts)
AC_CONFIG_SRCDIR([Makefile.am])
AC_CONFIG_HEADERS([config.h])
+AC_USE_SYSTEM_EXTENSIONS
# Initialize Automake
AM_INIT_AUTOMAKE([foreign dist-xz])
@@ -40,6 +41,12 @@ XORG_DEFAULT_OPTIONS
# Checks for pkg-config packages
PKG_CHECK_MODULES(XLSFONTS, [x11 xproto >= 7.0.17])
+# Checks for library functions
+AC_SEARCH_LIBS([reallocarray], [bsd])
+AS_IF([test "x$ac_cv_search_reallocarray" = "x-lbsd"],
+ [AC_CHECK_HEADERS([bsd/stdlib.h])])
+AC_CHECK_FUNCS([reallocarray])
+
AC_CONFIG_FILES([
Makefile
man/Makefile])