summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorAlan Coopersmith <alan.coopersmith@sun.com>2007-07-17 11:04:16 -0700
committerAlan Coopersmith <alan.coopersmith@sun.com>2007-07-17 11:04:16 -0700
commit72a01c6a3bae2cf113ab0ec812df41fec9b99a51 (patch)
tree485b3aa5bc0acdd227cb0850485426581ef80128 /Makefile.am
parent4dfbd74bda684bea748fbbcbfc172f6325423d12 (diff)
Replace static ChangeLog with dist-hook to generate from git log
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am11
1 files changed, 11 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index c0e91ec..aedac7d 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -36,6 +36,8 @@ appman_PRE = \
xmodmap.man
EXTRA_DIST = \
+ ChangeLog \
+ autogen.sh \
swap.km
appmandir = $(APP_MAN_DIR)
@@ -68,3 +70,12 @@ SUFFIXES = .$(APP_MAN_SUFFIX) .man
.man.$(APP_MAN_SUFFIX):
sed $(MAN_SUBSTS) < $< > $@
+
+MAINTAINERCLEANFILES = ChangeLog
+
+.PHONY: ChangeLog
+
+ChangeLog:
+ (GIT_DIR=$(top_srcdir)/.git git-log > .changelog.tmp && mv .changelog.tmp ChangeLog; rm -f .changelog.tmp) || (touch ChangeLog; echo 'git directory not found: installing possibly empty changelog.' >&2)
+
+dist-hook: ChangeLog