summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorGaetan Nadon <memsize@videotron.ca>2011-01-19 10:06:57 -0500
committerGaetan Nadon <memsize@videotron.ca>2011-01-19 10:06:57 -0500
commit88f027eb5caafea16925b44e8da77e9837b4988e (patch)
tree4cf78ffc84700c4f8da1a7f2a898a79086609c5a /Makefile.am
parentc2e66dced98d62bbfe013e54f2332b9950a268b9 (diff)
config: move man pages into their own directory
Use services provided by XORG_MANPAGE_SECTIONS. Use standard Makefile for man pages. Signed-off-by: Gaetan Nadon <memsize@videotron.ca>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am18
1 files changed, 1 insertions, 17 deletions
diff --git a/Makefile.am b/Makefile.am
index 7aaec10..9987787 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -19,6 +19,7 @@
# TORTIOUS ACTION, ARISING OUT OF OR IN CONNECTION WITH THE USE OR
# PERFORMANCE OF THIS SOFTWARE.
+SUBDIRS = man
bin_PROGRAMS = xstdcmap
AM_CFLAGS = $(XSTDCMAP_CFLAGS) -D_BSD_SOURCE $(CWARNFLAGS)
@@ -27,24 +28,7 @@ xstdcmap_LDADD = $(XSTDCMAP_LIBS)
xstdcmap_SOURCES = \
xstdcmap.c
-appman_PRE = \
- xstdcmap.man
-
-
-appmandir = $(APP_MAN_DIR)
-
-appman_DATA = $(appman_PRE:man=@APP_MAN_SUFFIX@)
-
-EXTRA_DIST = $(appman_PRE)
MAINTAINERCLEANFILES = ChangeLog INSTALL
-CLEANFILES = $(appman_DATA)
-
-SUFFIXES = .$(APP_MAN_SUFFIX) .man
-
-# String replacements in MAN_SUBSTS now come from xorg-macros.m4 via configure
-.man.$(APP_MAN_SUFFIX):
- $(AM_V_GEN)$(SED) $(MAN_SUBSTS) < $< > $@
-
.PHONY: ChangeLog INSTALL