summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gmail.com>2011-05-25 18:16:22 +0200
committerPeter Hutterer <peter.hutterer@who-t.net>2011-05-26 12:11:34 +1000
commit6eb829e07e455a8a04dabae7f257dd42a9b8bcdf (patch)
treee01c73294f4f852ce22e43fe5b033af9841ccaac /Makefile.am
parentdac624ad2b3a67ab93c11d8ee0a91b217fc1afe6 (diff)
build: apply the distcheck tricks used in xf86-input-evdev
With this change it is possible to complete "make distcheck" safely on the module, as it no longer tries to write to system directories. Since synaptics also installs a configuration file, xorg-conf-dir also needs to be overridden during distcheck. Signed-off-by: Diego Elio Pettenò <flameeyes@gmail.com> Signed-off-by: Peter Hutterer <peter.hutterer@who-t.net>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am6
1 files changed, 6 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 07cb902..e94fe19 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -18,6 +18,12 @@
# IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM, OUT OF OR IN
# CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE SOFTWARE.
+# During distcheck, system locations (as provided by pkg-config) are
+# not writable; provide instead relative locations.
+DISTCHECK_CONFIGURE_FLAGS = \
+ --with-sdkdir='$${includedir}/xorg' \
+ --with-xorg-conf-dir='$${sysconfdir}/xorg'
+
MAINTAINERCLEANFILES = ChangeLog INSTALL
pkgconfigdir = $(libdir)/pkgconfig