summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorPeter Hutterer <peter.hutterer@who-t.net>2012-03-23 16:19:18 +1000
committerPeter Hutterer <peter.hutterer@who-t.net>2012-05-10 09:42:54 +1000
commit3430f4af41184752d698dcbf4919469e36b3216c (patch)
treeb546d98eb578af7fc946c2b21e42fd5ef4ee7b4e /configure.ac
parent13611cd34e267370690e06bef6a02064927c2078 (diff)
Require xserver 1.12 and inputproto 2.2
This drops conditional compilation of multitouch support, smooth scrolling support and old ABIs. Signed-off-by: Peter Hutterer <peter.hutterer@who-t.net> Acked-by: Chase Douglas <chase.douglas@canonical.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac13
1 files changed, 3 insertions, 10 deletions
diff --git a/configure.ac b/configure.ac
index 7996106..2b3ee75 100644
--- a/configure.ac
+++ b/configure.ac
@@ -54,7 +54,7 @@ m4_ifndef([XORG_DRIVER_CHECK_EXT],
XORG_DRIVER_CHECK_EXT(RANDR, randrproto)
# Obtain compiler/linker options for the Synaptics driver dependencies
-PKG_CHECK_MODULES(XORG, [xorg-server >= 1.7] xproto inputproto $REQUIRED_MODULES)
+PKG_CHECK_MODULES(XORG, [inputproto >= 2.1.99.3] [xorg-server >= 1.12] xproto inputproto $REQUIRED_MODULES)
# X Server SDK location is required to install Synaptics header files
# This location is also relayed in the xorg-synaptics.pc file
@@ -64,11 +64,6 @@ AC_SUBST([sdkdir])
DRIVER_NAME=synaptics
AC_SUBST([DRIVER_NAME])
-PKG_CHECK_MODULES(XI22, [inputproto >= 2.1.99.3] [xorg-server >= 1.11.99.901], HAVE_XI22="yes", HAVE_XI22="no")
-if test "x$HAVE_XI22" = xyes; then
- AC_DEFINE(HAVE_MULTITOUCH, 1, [XI2.2 available])
-fi
-
# -----------------------------------------------------------------------------
# Configuration options
# -----------------------------------------------------------------------------
@@ -126,10 +121,8 @@ esac
if test "x$BUILD_EVENTCOMM" = xyes; then
AC_DEFINE(BUILD_EVENTCOMM, 1, [Optional backend eventcomm enabled])
- if test "x$HAVE_XI22" = xyes; then
- # Obtain compiler/linker options for mtdev
- PKG_CHECK_MODULES(MTDEV, mtdev)
- fi
+ # Obtain compiler/linker options for mtdev
+ PKG_CHECK_MODULES(MTDEV, mtdev)
fi
if test "x$BUILD_PSMCOMM" = xyes; then
AC_DEFINE(BUILD_PSMCOMM, 1, [Optional backend psmcomm enabled])