summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorMatthieu Herrb <matthieu@herrb.eu>2014-07-12 15:43:55 +0200
committerMatthieu Herrb <matthieu@herrb.eu>2024-08-02 08:35:27 +0200
commit5b12f7b4d8993eb16342e33c98f533a5344c1abd (patch)
tree5297e1daf545ec53397635561fa94f687de3ebcd /configure.ac
parentc3ca682a027262cf8659611c94899e25e5e2f1bc (diff)
OpenBSD wsconscomm support from shadchin@HEADobsd
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac8
1 files changed, 8 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 1a96457..bd64c2a 100644
--- a/configure.ac
+++ b/configure.ac
@@ -115,6 +115,10 @@ case "${host}" in
AC_MSG_RESULT([ps2comm alpscomm])
BUILD_PS2COMM="yes"
;;
+*openbsd*)
+ AC_MSG_RESULT([wsconscomm])
+ BUILD_WSCONSCOMM="yes"
+ ;;
*)
AC_MSG_ERROR([Cannot find suitable backends for this platform.])
;;
@@ -136,9 +140,13 @@ fi
if test "x$BUILD_PS2COMM" = xyes; then
AC_DEFINE(BUILD_PS2COMM, 1, [Optional backend ps2comm and alpscomm enabled])
fi
+if test "x$BUILD_WSCONSCOMM" = xyes; then
+ AC_DEFINE(BUILD_WSCONSCOMM, 1, [Optional backend wsconscomm enabled])
+fi
AM_CONDITIONAL([BUILD_EVENTCOMM], [test "x${BUILD_EVENTCOMM}" = "xyes"])
AM_CONDITIONAL([BUILD_PSMCOMM], [test "x${BUILD_PSMCOMM}" = "xyes"])
AM_CONDITIONAL([BUILD_PS2COMM], [test "x${BUILD_PS2COMM}" = "xyes"])
+AM_CONDITIONAL([BUILD_WSCONSCOMM], [test "x${BUILD_WSCONSCOMM}" = "xyes"])
# -----------------------------------------------------------------------------
# Dependencies for synclient and syndaemon