summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorAlan Coopersmith <alan.coopersmith@oracle.com>2022-10-17 10:25:25 -0700
committerAlan Coopersmith <alan.coopersmith@oracle.com>2022-10-17 10:53:55 -0700
commitf9dcbd53e7c63918b4798d961b56d28e55c9787f (patch)
tree1386a3f16d0b55119390c3d84300ba2b6248a968 /configure.ac
parent8026dbf57d657a2ff1d6bd6037082c11682f49bb (diff)
WriteAST1180SOC: Add _X_UNUSED attribute to temp variable
Clears 67 out of 84 warnings of the form: In file included from ast_cursor.c:53:0: ast_cursor.c: In function ‘ASTLoadCursorImage’: ast_vgatool.h:149:15: warning: variable ‘temp’ set but not used [-Wunused-but-set-variable] ULONG temp; \ ^ ast_cursor.c:293:9: note: in expansion of macro ‘WriteAST1180SOC’ WriteAST1180SOC(AST1180_GFX_BASE+AST1180_HWC1_PATTERNADDR, ulPatternAddr); ^~~~~~~~~~~~~~~ Signed-off-by: Alan Coopersmith <alan.coopersmith@oracle.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index ae4d5d6..cb6b760 100644
--- a/configure.ac
+++ b/configure.ac
@@ -59,7 +59,7 @@ XORG_DRIVER_CHECK_EXT(XV, videoproto)
XORG_DRIVER_CHECK_EXT(DPMSExtension, xextproto)
# Obtain compiler/linker options for the driver dependencies
-PKG_CHECK_MODULES(XORG, [xorg-server >= 1.0.99.901 xproto fontsproto $REQUIRED_MODULES])
+PKG_CHECK_MODULES(XORG, [xorg-server >= 1.0.99.901 xproto >= 7.0.22 fontsproto $REQUIRED_MODULES])
# Checks for libraries.
SAVE_CPPFLAGS="$CPPFLAGS"