summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorMichel Dänzer <michel.daenzer@amd.com>2017-01-24 18:22:49 +0900
committerMichel Dänzer <michel@daenzer.net>2017-01-26 18:27:30 +0900
commit55a33205cb9bd8091b4bcd478c2d1d191248681b (patch)
tree745fa6d45c369c15fecd663076cdfb7c9918ed2e /configure.ac
parent8e6a4e96b7b27559e186f71b5547abb0a80b96dd (diff)
Add 10-radeon.conf xorg.conf.d snippet
This instructs Xorg >= 1.16 to try loading the radeon driver for devices managed by the radeon kernel driver, even if the ati wrapper driver isn't available. Copied from the amdgpu driver. Reviewed-by: Alex Deucher <alexander.deucher@amd.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac16
1 files changed, 16 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 48281e3a..732f7050 100644
--- a/configure.ac
+++ b/configure.ac
@@ -79,6 +79,20 @@ PKG_CHECK_MODULES(XEXT, [xextproto >= 7.0.99.1],
HAVE_XEXTPROTO_71="no")
AM_CONDITIONAL(HAVE_XEXTPROTO_71, [ test "$HAVE_XEXTPROTO_71" = "yes" ])
+# Section "OutputClass" is only supported as of xserver 1.16
+PKG_CHECK_EXISTS([xorg-server >= 1.16],
+ [sysconfigdir=`$PKG_CONFIG --variable=sysconfigdir xorg-server`],
+ [sysconfigdir=""])
+AM_CONDITIONAL(HAS_XORG_CONF_DIR, [test "x$sysconfigdir" != "x"])
+
+# Define a configure option for an alternate X Server configuration directory
+AC_ARG_WITH(xorg-conf-dir,
+ AS_HELP_STRING([--with-xorg-conf-dir=DIR],
+ [Default xorg.conf.d directory [[default=${prefix}/share/X11/xorg.conf.d]]]),
+ [configdir="$withval"],
+ [configdir='${prefix}/share/X11/xorg.conf.d'])
+AC_SUBST(configdir)
+
AC_ARG_ENABLE([udev],
AS_HELP_STRING([--disable-udev], [Disable libudev support [default=auto]]),
[enable_udev="$enableval"],
@@ -265,6 +279,7 @@ AC_CONFIG_FILES([
Makefile
src/Makefile
man/Makefile
+ conf/Makefile
])
AC_OUTPUT
@@ -276,6 +291,7 @@ echo " prefix: $prefix"
echo " exec_prefix: $exec_prefix"
echo " libdir: $libdir"
echo " includedir: $includedir"
+echo " configdir: $configdir"
echo ""
echo " CFLAGS: $CFLAGS"