summaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorDave Airlie <airlied@redhat.com>2012-06-15 10:05:03 +0100
committerDave Airlie <airlied@redhat.com>2012-06-15 15:41:52 +0100
commit18d5ae3bd9075ac1a2ee21b071ac133e2e634b62 (patch)
tree82e60e279e52956df3c4d4f124c8d489d2ed106d /src/Makefile.am
parent248e912c487636d7352cfad43c03fc9f19fc2215 (diff)
radeon: drop all UMS/DRI1/XAA/overlay support.
This overhauls the radeon driver and removes all the old UMS-only code, it drops all the UMS, DRI1, XAA, overlay Xv, video capture, tv tuners There are probably a lot more cleanups that will fall out of this afterwards. So far this is compile/build tested. Signed-off-by: Dave Airlie <airlied@redhat.com>
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am80
1 files changed, 6 insertions, 74 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 26ceda7f..20d65513 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -28,47 +28,15 @@
radeon_drv_la_LIBADD = $(LIBDRM_RADEON_LIBS)
-if DRI
-RADEON_DRI_SRCS = radeon_dri.c
-radeon_drv_la_LIBADD += $(DRI_LIBS)
-endif
-
-RADEON_ATOMBIOS_SOURCES = \
- AtomBios/CD_Operations.c \
- AtomBios/Decoder.c \
- AtomBios/hwserv_drv.c \
- AtomBios/includes/atombios.h \
- AtomBios/includes/CD_binding.h \
- AtomBios/includes/CD_Common_Types.h \
- AtomBios/includes/CD_Definitions.h \
- AtomBios/includes/CD_hw_services.h \
- AtomBios/includes/CD_Opcodes.h \
- AtomBios/includes/CD_Structs.h \
- AtomBios/includes/Decoder.h \
- AtomBios/includes/ObjectID.h \
- AtomBios/includes/regsdef.h
-
-if XF86DRM_MODE
RADEON_KMS_SRCS=radeon_dri2.c radeon_kms.c drmmode_display.c radeon_vbo.c
-endif
-if USE_EXA
RADEON_EXA_SOURCES = radeon_exa.c r600_exa.c r6xx_accel.c r600_textured_videofuncs.c r600_shader.c radeon_exa_shared.c \
evergreen_exa.c evergreen_accel.c evergreen_shader.c evergreen_textured_videofuncs.c cayman_accel.c cayman_shader.c
-endif
AM_CFLAGS = \
@LIBDRM_RADEON_CFLAGS@ \
@XORG_CFLAGS@ \
- @DRI_CFLAGS@ \
- @LIBUDEV_CFLAGS@ \
- -DDISABLE_EASF \
- -DENABLE_ALL_SERVICE_FUNCTIONS \
- -DATOM_BIOS \
- -DATOM_BIOS_PARSER \
- -DDRIVER_PARSER
-
-INCLUDES = -I$(srcdir)/AtomBios/includes
+ @LIBUDEV_CFLAGS@
if XSERVER_LIBPCIACCESS
ati_drv_la_LIBADD = $(PCIACCESS_LIBS)
@@ -89,40 +57,14 @@ radeon_drv_la_LTLIBRARIES = radeon_drv.la
radeon_drv_la_LDFLAGS = -module -avoid-version
radeon_drv_ladir = @moduledir@/drivers
radeon_drv_la_SOURCES = \
- radeon_accel.c radeon_cursor.c radeon_legacy_memory.c \
- radeon_driver.c radeon_video.c radeon_bios.c radeon_mm_i2c.c \
- radeon_vip.c radeon_misc.c radeon_probe.c \
- legacy_crtc.c legacy_output.c \
- radeon_textured_video.c radeon_xvmc.c radeon_pm.c \
- radeon_crtc.c radeon_output.c radeon_modes.c radeon_tv.c \
- $(RADEON_ATOMBIOS_SOURCES) radeon_atombios.c radeon_atomwrapper.c \
- $(RADEON_DRI_SRCS) $(RADEON_EXA_SOURCES) atombios_output.c atombios_crtc.c \
+ radeon_accel.c radeon_legacy_memory.c \
+ radeon_driver.c radeon_video.c \
+ radeon_misc.c radeon_probe.c \
+ radeon_textured_video.c radeon_xvmc.c \
+ $(RADEON_EXA_SOURCES) \
$(RADEON_KMS_SRCS)
-theatre_detect_drv_la_LTLIBRARIES = theatre_detect_drv.la
-theatre_detect_drv_la_LDFLAGS = -module -avoid-version
-theatre_detect_drv_ladir = @moduledir@/multimedia
-theatre_detect_drv_la_SOURCES = \
- theatre_detect.c theatre_detect_module.c
-
-theatre_drv_la_LTLIBRARIES = theatre_drv.la
-theatre_drv_la_LDFLAGS = -module -avoid-version
-theatre_drv_ladir = @moduledir@/multimedia
-
-theatre_drv_la_SOURCES = \
- theatre.c theatre_module.c
-
-theatre200_drv_la_LTLIBRARIES = theatre200_drv.la
-theatre200_drv_la_LDFLAGS = -module -avoid-version
-theatre200_drv_ladir = @moduledir@/multimedia
-theatre200_drv_la_CFLAGS = \
- $(AM_CFLAGS) -DMICROC_DIR=\"$(theatre200_drv_ladir)\"
-theatre200_drv_la_SOURCES = \
- theatre200.c theatre200_module.c
-
EXTRA_DIST = \
- radeon_render.c \
- radeon_accelfuncs.c \
radeon_textured_videofuncs.c \
r600_reg.h \
r600_reg_auto_r6xx.h \
@@ -141,11 +83,8 @@ EXTRA_DIST = \
ati.h \
ativersion.h \
bicubic_table.h \
- generic_bus.h \
radeon_commonfuncs.c \
- radeon_dri.h \
radeon_drm.h \
- radeon_dummy_bufmgr.h \
radeon_exa_render.c \
radeon_exa_funcs.c \
radeon_exa_shared.h \
@@ -156,13 +95,7 @@ EXTRA_DIST = \
radeon_version.h \
radeon_vbo.h \
radeon_video.h \
- radeon_tv.h \
- radeon_atomwrapper.h \
simple_list.h \
- theatre200.h \
- theatre_detect.h \
- theatre.h \
- theatre_reg.h \
atipciids.h \
atipcirename.h \
ati_pciids_gen.h \
@@ -172,6 +105,5 @@ EXTRA_DIST = \
radeon_pci_device_match_gen.h \
pcidb/ati_pciids.csv \
pcidb/parse_pci_ids.pl \
- radeon_atombios.h \
radeon_dri2.h \
drmmode_display.h