summaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorMichel Dänzer <michel.daenzer@amd.com>2013-01-10 12:10:52 +0100
committerMichel Dänzer <michel@daenzer.net>2013-01-10 12:10:52 +0100
commit4e35b2f530e2ca8c7b7220cacd05c661de43d20d (patch)
tree845f6d7b671a3ec668d4229bb56799fc9f0a6167 /src/Makefile.am
parent857d729eb3672443f89c0516f8226eacb37dad2b (diff)
Drop support for X servers older than 1.7.
The main purpose is to drop DRI2 compatibility code paths which are getting awkward to deal with and at this point are probably only tested lightly if at all. xserver 1.7 was released more than 3 years ago, and 1.6.2 was already required before. Mostly mechanical, there's probably potential for more cleanups. Reviewed-by: Alex Deucher <alexander.deucher@amd.com> Signed-off-by: Michel Dänzer <michel.daenzer@amd.com>
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am8
1 files changed, 2 insertions, 6 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index da94927f..6b7171ee 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -26,7 +26,8 @@
# _ladir passes a dummy rpath to libtool so the thing will actually link
# TODO: -nostdlib/-Bstatic/-lgcc platform magic, not installing the .a, etc.
-radeon_drv_la_LIBADD = $(LIBDRM_RADEON_LIBS)
+ati_drv_la_LIBADD = $(PCIACCESS_LIBS)
+radeon_drv_la_LIBADD = $(LIBDRM_RADEON_LIBS) $(PCIACCESS_LIBS)
RADEON_KMS_SRCS=radeon_dri2.c radeon_kms.c drmmode_display.c radeon_vbo.c \
radeon_bo_helper.c
@@ -39,11 +40,6 @@ AM_CFLAGS = \
@XORG_CFLAGS@ \
@LIBUDEV_CFLAGS@
-if XSERVER_LIBPCIACCESS
-ati_drv_la_LIBADD = $(PCIACCESS_LIBS)
-radeon_drv_la_LIBADD += $(PCIACCESS_LIBS)
-endif
-
if LIBUDEV
radeon_drv_la_LIBADD += $(LIBUDEV_LIBS)
endif