summaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorDave Airlie <airlied@redhat.com>2010-04-16 13:58:54 +1000
committerDave Airlie <airlied@redhat.com>2010-04-16 13:58:54 +1000
commita69e749d0562887af6bd236c38802472e54640c4 (patch)
tree2b2ddc0be5e2c10bc64d96ceff997caf06c5a705 /src/Makefile.am
parent22a46dddd375b2b9399e12fdf168fa5292ff17a4 (diff)
kms: add uevent support.
When we get a hotplug event from the kernel we should notify the client side to reconfigure displays. based on work by ajax in intel driver. Signed-off-by: Dave Airlie <airlied@redhat.com>
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am5
1 files changed, 5 insertions, 0 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 0f89480e..0ce46b08 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -78,6 +78,7 @@ AM_CFLAGS = \
@XORG_CFLAGS@ \
@DRI_CFLAGS@ \
@XMODES_CFLAGS@ \
+ @LIBUDEV_CFLAGS@ \
-DDISABLE_EASF \
-DENABLE_ALL_SERVICE_FUNCTIONS \
-DATOM_BIOS \
@@ -91,6 +92,10 @@ ati_drv_la_LIBADD = $(PCIACCESS_LIBS)
radeon_drv_la_LIBADD += $(PCIACCESS_LIBS)
endif
+if LIBUDEV
+radeon_drv_la_LIBADD += $(LIBUDEV_LIBS)
+endif
+
ati_drv_la_LTLIBRARIES = ati_drv.la
ati_drv_la_LDFLAGS = -module -avoid-version
ati_drv_ladir = @moduledir@/drivers