summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorEnrico Weigelt, metux IT consult <info@metux.net>2024-05-27 18:02:54 +0200
committerEnrico Weigelt, metux IT consult <info@metux.net>2024-06-11 14:13:32 +0200
commit1bd62d4e151931e41e879ea4cb28b3a6a0600978 (patch)
tree25336c86178b2174b99ea241c7ad994b8287e5d1 /configure.ac
parent83b14d6e438d7250e1bc018ee0929f5779bf551c (diff)
drop obsolete XAA support
Since recent commits require xserver-1.18.0 or later to build against, there's no reason leaving behind big chunks of code that can only build against the XAA support removed in xserver-1.13.0 (released in 2012). Signed-off-by: Enrico Weigelt, metux IT consult <info@metux.net>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac27
1 files changed, 0 insertions, 27 deletions
diff --git a/configure.ac b/configure.ac
index 410fbce..75f6a23 100644
--- a/configure.ac
+++ b/configure.ac
@@ -129,33 +129,6 @@ PKG_CHECK_MODULES(XEXT, [xextproto >= 7.0.99.1],
HAVE_XEXTPROTO_71="yes"; AC_DEFINE(HAVE_XEXTPROTO_71, 1, [xextproto 7.1 available]),
HAVE_XEXTPROTO_71="no")
-# Define a configure option to enable/disable XAA support;
-# handles unavailability of XAA since xserver-1.13
-AC_ARG_ENABLE(xaa,
- AS_HELP_STRING([--enable-xaa],
- [Enable legacy X Acceleration Architecture (XAA) [default=auto]]))
-
-AS_IF([test "x$enable_xaa" != "xno"],
- [
- save_CFLAGS=$CFLAGS
- save_CPPFLAGS=$CPPFLAGS
- CFLAGS=$XORG_CFLAGS
- CPPFLAGS="$XORG_CFLAGS"
- AC_CHECK_HEADERS([xaa.h], have_XAA=yes, have_XAA=no)
- CFLAGS=$save_CFLAGS
- CPPFLAGS=$save_CPPFLAGS
-])
-
-AC_MSG_CHECKING([whether to include XAA support])
-
-AS_IF([test "x$have_XAA" = "xyes"],
- [AC_MSG_RESULT([yes])],
- [AS_IF([test "x$enable_xaa" = "xyes"],
- [AC_MSG_ERROR([XAA requested but not found (perhaps building against xserver-1.13 or newer?)])],
- [AC_MSG_RESULT([no])
- ])
-])
-
# Checks for libpciaccess support.
SAVE_CPPFLAGS="$CPPFLAGS"
CPPFLAGS="$CPPFLAGS $XORG_CFLAGS"