summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorGaetan Nadon <memsize@videotron.ca>2011-11-17 09:32:24 -0500
committerMartin-Éric Racine <martin-eric.racine@iki.fi>2011-11-21 10:33:10 +0200
commit60c3f5f7e9482d29f043504860319aeead7b9a69 (patch)
treeb987ac8035f5f53d972e0076c105e14402dd5be7 /configure.ac
parent5f228208cc65348e35aa24b6cddae1df19b67fa5 (diff)
Remove duplicate warning variable and werror option
Use already existing: --enable-strict-compilation Enable all warnings from compiler and make them errors (default: disabled) which, byt the way was broken as it was not implemented in geode. Use already existing CWARNINGFLAGS variable, so there is no need to define GCC_WARNINGS. Both come from util-macros version 1.4 or later. http://cgit.freedesktop.org/xorg/util/macros/tree/xorg-macros.m4.in ?id=03b04a6b5d61aafbd2705f7d29e58e0c92553a4a If you configure with a later version of util-macros you may see new warnings appear as additional flags have been added over the years. You get better support for platforms/compiler differences. Signed-off-by: Gaetan Nadon <memsize@videotron.ca>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac15
1 files changed, 0 insertions, 15 deletions
diff --git a/configure.ac b/configure.ac
index 0b4045d..ec4f87e 100644
--- a/configure.ac
+++ b/configure.ac
@@ -60,10 +60,6 @@ AC_ARG_ENABLE(geodegx-panel,
[ ],
[ AMD_CFLAGS="-DPNL_SUP $AMD_CFLAGS" ])
-AC_ARG_ENABLE(werror, AC_HELP_STRING([--enable-werror],
- [Treat warnings as errors (default: disabled)]),
- [WERROR=$enableval], [WERROR=no])
-
# Define a configure option to enable/disable ztv
AC_ARG_ENABLE(ztv,
AS_HELP_STRING([--enable-ztv],
@@ -85,17 +81,6 @@ if test "x$ztv" != "xno" ; then
fi
AM_CONDITIONAL(BUILD_ZTV, [test "x$BUILD_ZTV" = xyes])
-if test "x$GCC" = "xyes"; then
- GCC_WARNINGS1="-Wall -Wpointer-arith -Wstrict-prototypes"
- GCC_WARNINGS2="-Wmissing-prototypes -Wmissing-declarations"
- GCC_WARNINGS3="-Wnested-externs -fno-strict-aliasing"
- GCC_WARNINGS="$GCC_WARNINGS1 $GCC_WARNINGS2 $GCC_WARNINGS3"
- if test "x$WERROR" = "xyes"; then
- GCC_WARNINGS="${GCC_WARNINGS} -Werror"
- fi
- AMD_CFLAGS="$GCC_WARNINGS $AMD_CFLAGS"
-fi
-
# Checks for extensions
XORG_DRIVER_CHECK_EXT(RANDR, randrproto)
XORG_DRIVER_CHECK_EXT(RENDER, renderproto)