summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorChris Wilson <chris@chris-wilson.co.uk>2016-03-24 12:28:59 +0000
committerChris Wilson <chris@chris-wilson.co.uk>2016-03-24 12:31:08 +0000
commit4e108afe55f6b13aa946d1252ff0b828929245b3 (patch)
treee593851f20b8c004d243e5a03606e99b5f73f81e /configure.ac
parentc326ed192bcaeea41bb93b7077ec37a1437a4409 (diff)
Revert "configure: Remove test for strlcat"
This reverts commit e4e469a0ede6974e1f916843f9317244516f7674. It looks like we get to choose between breaking the clang build or the gcc build. With gcc, we need to ensure that enter xorg/os.h with the right set of HAVE_STRNDUP et al guards, e.g. In file included from /usr/include/string.h:630:0, from /usr/include/xorg/os.h:53, from /usr/include/xorg/misc.h:116, from fd.c:34: /usr/include/xorg/os.h:590:1: error: expected identifier or '(' before '__extension__' strndup(const char *str, size_t n); Reported-by: Arkadiusz Miskiewicz <arekm@maven.pl> Signed-off-by: Chris Wilson <chris@chris-wilson.co.uk>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac3
1 files changed, 3 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index b121515f..c18ad96c 100644
--- a/configure.ac
+++ b/configure.ac
@@ -62,6 +62,9 @@ AC_DISABLE_STATIC
AC_PROG_LIBTOOL
AC_SYS_LARGEFILE
+# Check for common libc routines redefined by os.h
+AC_CHECK_FUNCS([strlcpy strlcat strndup], [], [])
+
# Platform specific settings
case $host_os in
*linux*)