summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorChris Wilson <chris@chris-wilson.co.uk>2011-06-09 12:59:59 +0100
committerChris Wilson <chris@chris-wilson.co.uk>2011-06-09 12:59:59 +0100
commit6f59d7d19053fed4e9d6402a5f03bc8a62cb56af (patch)
tree14141019245e394a43b4c15e93736f8ce9b36a0f /configure.ac
parent021209d5d3add8b28143611cfad4c5481a2945a3 (diff)
sna: Use --enable-debug=full to enable extremely verbose debugging
Signed-off-by: Chris Wilson <chris@chris-wilson.co.uk>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac7
1 files changed, 5 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 17764891..31106afc 100644
--- a/configure.ac
+++ b/configure.ac
@@ -224,13 +224,16 @@ if test "x$SNA" != xno; then
fi
AC_MSG_RESULT([$sna_drivers])
-AM_CONDITIONAL(DEBUG, test x$DEBUG = xyes)
+AM_CONDITIONAL(DEBUG, test x$DEBUG != xno)
if test "x$DEBUG" = xno; then
AC_DEFINE(NDEBUG,1,[Disable internal debugging])
fi
-if test "x$DEBUG" = xyes; then
+if test "x$DEBUG" != xno; then
AC_DEFINE(HAS_EXTRA_DEBUG,1,[Enable additional debugging])
fi
+if test "x$DEBUG" = xfull; then
+ AC_DEFINE(HAS_DEBUG_FULL,1,[Enable all debugging])
+fi
AC_CHECK_HEADERS([sys/timerfd.h])