summaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorChris Wilson <chris@chris-wilson.co.uk>2013-06-22 17:30:02 +0100
committerChris Wilson <chris@chris-wilson.co.uk>2013-06-23 07:33:56 +0100
commit7ec0378b64e88923ba1c4eba043488685aa3a795 (patch)
tree1d11f3c1bbc292083fb2f8fd86c40d40fe21d921 /src/Makefile.am
parent41badce186fe0f6e8f49e30b6c1c251027161e35 (diff)
sna: Only open the /dev/dri/cardX device once
Merge the device open in the main driver with the probing so that we can open the path explicitly passed in by the PlatformProbe and keep that fd around for the main driver and so avoid a later search. Signed-off-by: Chris Wilson <chris@chris-wilson.co.uk>
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am55
1 files changed, 28 insertions, 27 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 80837568..27b702bf 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -43,6 +43,7 @@ NULL:=#
intel_drv_la_SOURCES = \
intel_list.h \
intel_options.h \
+ intel_device.c \
intel_options.c \
intel_module.c \
compat-api.h \
@@ -53,33 +54,33 @@ AM_CFLAGS += @UDEV_CFLAGS@ @DRM_CFLAGS@ @DRMINTEL_CFLAGS@
AM_CFLAGS += -I$(top_srcdir)/uxa -I$(top_srcdir)/src/render_program
intel_drv_la_LIBADD += @UDEV_LIBS@ @DRMINTEL_LIBS@ @DRM_LIBS@ ../uxa/libuxa.la
intel_drv_la_SOURCES += \
- brw_defines.h \
- brw_structs.h \
- common.h \
- intel.h \
- intel_batchbuffer.c \
- intel_batchbuffer.h \
- intel_display.c \
- intel_driver.c \
- intel_driver.h \
- intel_glamor.h \
- intel_memory.c \
- intel_uxa.c \
- intel_video.c \
- intel_video.h \
- i830_3d.c \
- i830_render.c \
- i830_reg.h \
- i915_3d.h \
- i915_reg.h \
- i915_3d.c \
- i915_render.c \
- i915_video.c \
- i965_reg.h \
- i965_3d.c \
- i965_video.c \
- i965_render.c \
- $(NULL)
+ brw_defines.h \
+ brw_structs.h \
+ common.h \
+ intel.h \
+ intel_batchbuffer.c \
+ intel_batchbuffer.h \
+ intel_display.c \
+ intel_driver.c \
+ intel_driver.h \
+ intel_glamor.h \
+ intel_memory.c \
+ intel_uxa.c \
+ intel_video.c \
+ intel_video.h \
+ i830_3d.c \
+ i830_render.c \
+ i830_reg.h \
+ i915_3d.h \
+ i915_reg.h \
+ i915_3d.c \
+ i915_render.c \
+ i915_video.c \
+ i965_reg.h \
+ i965_3d.c \
+ i965_video.c \
+ i965_render.c \
+ $(NULL)
if GLAMOR
AM_CFLAGS += @LIBGLAMOR_CFLAGS@