summaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorRémi Cardona <remi@gentoo.org>2009-10-28 12:37:38 +0100
committerRémi Cardona <remi@gentoo.org>2009-11-05 16:58:34 +0100
commita851139c2141f6da370186148f2836e18b2acf83 (patch)
treee93d1e6009a4a994df165b6429f60ba92a6c6804 /src/Makefile.am
parent07e0b2cff6107d6c86096c7da4e31b0c976794d5 (diff)
configure: make --disable-dri work even if the server supports DRI
XF86DRI is defined by the SDK so not defining it here just breaks the build. Define HAVE_DRI instead to avoid collisions. Note: DRI2 is still enabled/disabled entirely by SDK defines. Signed-off-by: Rémi Cardona <remi@gentoo.org> Acked-by: Chris Wilson <chris@chris-wilson.co.uk>
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am4
1 files changed, 1 insertions, 3 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 3b6e64d0..5ffb5220 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -26,7 +26,7 @@ SUBDIRS = xvmc bios_reader reg_dumper render_program
# _ladir passes a dummy rpath to libtool so the thing will actually link
# TODO: -nostdlib/-Bstatic/-lgcc platform magic, not installing the .a, etc.
-AM_CFLAGS = @WARN_CFLAGS@ @XORG_CFLAGS@ @DRM_CFLAGS@ @DRI_CFLAGS@ \
+AM_CFLAGS = @WARN_CFLAGS@ @XORG_CFLAGS@ @DRM_CFLAGS@ \
@PCIACCESS_CFLAGS@ -I$(top_srcdir)/uxa -I$(top_srcdir)/src/render_program
intel_drv_la_LTLIBRARIES = intel_drv.la
@@ -99,8 +99,6 @@ EXTRA_DIST = \
if DRI
intel_drv_la_SOURCES += \
$(INTEL_DRI_SRCS)
-intel_drv_la_LIBADD += \
- $(DRI_LIBS)
endif
if XVMC