summaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorZhigang Gong <zhigang.gong@linux.intel.com>2011-11-16 15:04:36 +0800
committerChris Wilson <chris@chris-wilson.co.uk>2011-11-17 01:10:21 +0000
commitfbabe60f48006ee664c983082498a863e8beec71 (patch)
treee0b76a3ee86fcb9b746565a7971ff52c979a0e24 /src/Makefile.am
parentc4c2eb1fae2518578a56a278afeaec66d544439d (diff)
glamor: Initial commit to introduce glamor acceleration.
Added one configuration option --enable-glamor to control whether use glamor. Added one new file intel_glamor.c to wrap glamor egl API for intel driver's usage. This commit doesn't really change the driver's control path. It just adds necessary files for glamor and change some configuration. Reviewed-by: Eugeni Dodonov <eugeni.dodonov@intel.com> Signed-off-by: Zhigang Gong <zhigang.gong@linux.intel.com> Signed-off-by: Chris Wilson <chris@chris-wilson.co.uk>
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am7
1 files changed, 7 insertions, 0 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index e5097daf..e821b94b 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -58,6 +58,7 @@ intel_drv_la_SOURCES += \
intel_display.c \
intel_driver.c \
intel_driver.h \
+ intel_glamor.h \
intel_memory.c \
intel_shadow.c \
intel_uxa.c \
@@ -77,6 +78,12 @@ intel_drv_la_SOURCES += \
i965_render.c \
$(NULL)
+if GLAMOR
+intel_drv_la_SOURCES += \
+ intel_glamor.c \
+ $(NULL)
+endif
+
if DRI
intel_drv_la_SOURCES += \
intel_dri.c \