summaryrefslogtreecommitdiff
path: root/src/legacy/i810/Makefile.am
diff options
context:
space:
mode:
authorDaniel Stone <daniel@fooishbar.org>2012-07-10 00:32:13 +0100
committerChris Wilson <chris@chris-wilson.co.uk>2012-07-10 09:36:40 +0100
commit232217eef8f99f5678d65bf9aa5b898ef6d3b3c6 (patch)
tree22d00db9c82250c2e971b08cc312f51233efe117 /src/legacy/i810/Makefile.am
parent78dc0c04745ad4485b994f67833f4a155749f01d (diff)
i810: Make DGA optional
Don't build DGA when it's not available, or when we don't want it. Signed-off-by: Chris Wilson <chris@chris-wilson.co.uk>
Diffstat (limited to 'src/legacy/i810/Makefile.am')
-rw-r--r--src/legacy/i810/Makefile.am6
1 files changed, 5 insertions, 1 deletions
diff --git a/src/legacy/i810/Makefile.am b/src/legacy/i810/Makefile.am
index 01cc2183..07a384f6 100644
--- a/src/legacy/i810/Makefile.am
+++ b/src/legacy/i810/Makefile.am
@@ -10,7 +10,6 @@ AM_CFLAGS = @CWARNFLAGS@ @XORG_CFLAGS@ @DRM_CFLAGS@ @DRI_CFLAGS@ @PCIACCESS_CFLA
liblegacy_i810_la_SOURCES = \
i810_common.h \
i810_cursor.c \
- i810_dga.c \
i810_driver.c \
i810.h \
i810_memory.c \
@@ -24,6 +23,11 @@ liblegacy_i810_la_SOURCES += \
i810_accel.c
endif
+if DGA
+liblegacy_i810_la_SOURCES += \
+ i810_dga.c
+endif
+
if DRI
liblegacy_i810_la_SOURCES +=\
i810_dri.c \