summaryrefslogtreecommitdiff
path: root/src/sna/Makefile.am
diff options
context:
space:
mode:
authorChris Wilson <chris@chris-wilson.co.uk>2011-07-01 14:55:44 +0100
committerChris Wilson <chris@chris-wilson.co.uk>2011-07-01 21:41:23 +0100
commit120c98ac10435c8e848a8337c1f544f81a05cd3a (patch)
tree2c69846fad530f2d45d29ebfcae2783955b3872a /src/sna/Makefile.am
parentf6c8c3bb6fd75bca6c7704b7d5869a5d44ce3832 (diff)
sna: Downsample sources 2x too large to fit in the 3D pipeline
This is quite trivial to hit given the 2k limits on gen2/gen3. We compromise on image quality by pre-downscaling the source by a fixed factor to make it fit into the pipeline in preference to performing the entire operation on the CPU. Signed-off-by: Chris Wilson <chris@chris-wilson.co.uk>
Diffstat (limited to 'src/sna/Makefile.am')
-rw-r--r--src/sna/Makefile.am1
1 files changed, 1 insertions, 0 deletions
diff --git a/src/sna/Makefile.am b/src/sna/Makefile.am
index dfd8a57f..d76480da 100644
--- a/src/sna/Makefile.am
+++ b/src/sna/Makefile.am
@@ -90,6 +90,7 @@ if DEBUG
libsna_la_SOURCES += \
kgem_debug.c \
kgem_debug.h \
+ kgem_debug_gen2.c \
kgem_debug_gen3.c \
kgem_debug_gen4.c \
kgem_debug_gen5.c \