summaryrefslogtreecommitdiff
path: root/src/uxa/Makefile.am
diff options
context:
space:
mode:
authorKeith Packard <keithp@keithp.com>2014-07-24 10:27:55 -0700
committerKeith Packard <keithp@keithp.com>2014-09-12 13:51:14 -0700
commit616dea2c67847101fd43b5d89b556b3702c7f0bb (patch)
treebdcd3e4ec057deeab433f4958e2483cdb2c4074a /src/uxa/Makefile.am
parent57c67199d043f3a653436769f1a69947a96d9d5b (diff)
Rename uxa-specific functions and structs
This starts to separate uxa from the rest of the driver by renaming uxa-specific functions and structs to make it clear which portions of the driver are uxa-specific and which are common. Signed-off-by: Keith Packard <keithp@keithp.com> Acked-by: Eric Anholt <eric@anholt.net>
Diffstat (limited to 'src/uxa/Makefile.am')
-rw-r--r--src/uxa/Makefile.am4
1 files changed, 4 insertions, 0 deletions
diff --git a/src/uxa/Makefile.am b/src/uxa/Makefile.am
index 0e10a2bb..23b074de 100644
--- a/src/uxa/Makefile.am
+++ b/src/uxa/Makefile.am
@@ -25,6 +25,7 @@ AM_CFLAGS += -I$(top_srcdir)/xvmc -I$(top_srcdir)/src -I$(top_srcdir)/src/render
noinst_LTLIBRARIES = libuxa.la
libuxa_la_LIBADD = $(UDEV_LIBS) $(DRMINTEL_LIBS) $(DRM_LIBS)
libuxa_la_SOURCES = \
+ intel_uxa.h \
brw_defines.h \
brw_structs.h \
common.h \
@@ -38,6 +39,9 @@ libuxa_la_SOURCES = \
intel_uxa.c \
intel_video.c \
intel_video.h \
+ intel_video_overlay.c \
+ intel_video_overlay.h \
+ intel_uxa_video.c \
i830_3d.c \
i830_render.c \
i830_reg.h \