summaryrefslogtreecommitdiff
path: root/src/uxa/Makefile.am
diff options
context:
space:
mode:
authorChris Wilson <chris@chris-wilson.co.uk>2014-05-09 20:26:19 +0100
committerChris Wilson <chris@chris-wilson.co.uk>2014-06-02 08:32:11 +0100
commitdd6db82680b05cde4a47116b7096c054f3837e20 (patch)
treeaa977913aed14f1aff7f3843edc17f5e59d16a9a /src/uxa/Makefile.am
parent975b9798be77b30cbed485583d0ccb48318708f7 (diff)
uxa: Add DRI3 and miSyncShm support
Based on a patch by Keith Packard. Signed-off-by: Chris Wilson <chris@chris-wilson.co.uk>
Diffstat (limited to 'src/uxa/Makefile.am')
-rw-r--r--src/uxa/Makefile.am7
1 files changed, 7 insertions, 0 deletions
diff --git a/src/uxa/Makefile.am b/src/uxa/Makefile.am
index 4fa1b8cc..29a83296 100644
--- a/src/uxa/Makefile.am
+++ b/src/uxa/Makefile.am
@@ -80,6 +80,13 @@ libuxa_la_LIBADD += \
$(NULL)
endif
+if DRI3
+libuxa_la_SOURCES += \
+ intel_dri3.c \
+ intel_sync.c \
+ $(NULL)
+endif
+
if XVMC
AM_CFLAGS += -I$(top_srcdir)/xvmc
libuxa_la_SOURCES += \