summaryrefslogtreecommitdiff
path: root/tools/Makefile.am
diff options
context:
space:
mode:
authorChris Wilson <chris@chris-wilson.co.uk>2015-03-04 11:19:09 +0000
committerChris Wilson <chris@chris-wilson.co.uk>2015-03-04 11:20:50 +0000
commit8d76f90e2cd560c315595e679679cefbcf422fb4 (patch)
treef60d7cf975b6af2a10baa5ff9369830bcb02772f /tools/Makefile.am
parent3e390ec4110519746f2edbb3c38a40f0fc415430 (diff)
tools: Add simple tool to retrieve the current cursor from X
Slightly more funky would be to poke around in the CRTC, but that should require master. As it stands this should help verify that what X is supplying to the driver matches user expectations Signed-off-by: Chris Wilson <chris@chris-wilson.co.uk>
Diffstat (limited to 'tools/Makefile.am')
-rw-r--r--tools/Makefile.am10
1 files changed, 9 insertions, 1 deletions
diff --git a/tools/Makefile.am b/tools/Makefile.am
index 6c992f84..20f8a003 100644
--- a/tools/Makefile.am
+++ b/tools/Makefile.am
@@ -26,13 +26,21 @@ AM_CFLAGS = \
drivermandir = $(DRIVER_MAN_DIR)
policydir = $(datarootdir)/polkit-1/actions
+noinst_PROGRAMS =
+
if BUILD_TOOLS
bin_PROGRAMS = intel-virtual-output
driverman_DATA = intel-virtual-output.$(DRIVER_MAN_SUFFIX)
endif
+if BUILD_TOOL_CURSOR
+noinst_PROGRAMS += cursor
+cursor_CFLAGS = $(TOOL_CURSOR_CFLAGS)
+cursor_LDADD = $(TOOL_CURSOR_LIBS)
+endif
+
if X11_DRI3
-noinst_PROGRAMS = dri3info
+noinst_PROGRAMS += dri3info
dri3info_SOURCES = dri3info.c
dri3info_CFLAGS = $(X11_DRI3_CFLAGS) $(DRI_CFLAGS)
dri3info_LDADD = $(X11_DRI3_LIBS) $(DRI_LIBS)