summaryrefslogtreecommitdiff
path: root/tools/Makefile.am
diff options
context:
space:
mode:
authorJan Alexander Steffens (heftig) <jan.steffens@gmail.com>2014-02-15 17:53:16 +0100
committerChris Wilson <chris@chris-wilson.co.uk>2014-02-15 17:39:01 +0000
commitb71f3d8bd4d6773899c1bdc903911cf240e68ead (patch)
tree38475ca50f0709e9adce821b52289282d2b372a8 /tools/Makefile.am
parent3d629c91cfa98b75c6685c2a2003e64fd1b612c4 (diff)
Backlight helper build fixes
Don't hardcode $(prefix)/libexec Fix install hook when DESTDIR is set Bugzilla: https://bugs.freedesktop.org/show_bug.cgi?id=75028
Diffstat (limited to 'tools/Makefile.am')
-rw-r--r--tools/Makefile.am9
1 files changed, 4 insertions, 5 deletions
diff --git a/tools/Makefile.am b/tools/Makefile.am
index a5667f34..876e1b03 100644
--- a/tools/Makefile.am
+++ b/tools/Makefile.am
@@ -24,7 +24,6 @@ AM_CFLAGS = \
$(NULL)
drivermandir = $(DRIVER_MAN_DIR)
-backlight_helperdir = $(prefix)/libexec
policydir = $(datarootdir)/polkit-1/actions
if BUILD_TOOLS
@@ -33,12 +32,12 @@ driverman_DATA = intel-virtual-output.$(DRIVER_MAN_SUFFIX)
endif
if BUILD_BACKLIGHT_HELPER
-backlight_helper_PROGRAMS = xf86-video-intel-backlight-helper
+libexec_PROGRAMS = xf86-video-intel-backlight-helper
nodist_policy_DATA = org.x.xf86-video-intel.backlight-helper.policy
-backlight_helper = $(backlight_helperdir)/xf86-video-intel-backlight-helper
-install-data-hook:
- -chown root $(backlight_helper) && chmod u+s $(backlight_helper)
+backlight_helper = $(libexecdir)/xf86-video-intel-backlight-helper
+install-exec-hook:
+ -chown root $(DESTDIR)$(backlight_helper) && chmod u+s $(DESTDIR)$(backlight_helper)
endif
intel_virtual_output_CFLAGS = \