summaryrefslogtreecommitdiff
path: root/uxa/Makefile.am
diff options
context:
space:
mode:
authorKeith Packard <keithp@keithp.com>2008-07-29 22:57:09 -0700
committerKeith Packard <keithp@keithp.com>2008-08-05 15:29:50 -0700
commit59774e9aca2d743e82d616bb644d20ff6d60d492 (patch)
tree209dfbdbfa8eb9dbd9cfc7a41be3fa3a7ead19ac /uxa/Makefile.am
parentc2f0df4dc97c87539b66525a277c7d1e2c421f61 (diff)
Add UXA - the unified memory acceleration architecture.
This eliminates the cost of EXA migration management while providing full pixmap allocation control to the driver. The goal is to make something useful for UMA drivers.
Diffstat (limited to 'uxa/Makefile.am')
-rw-r--r--uxa/Makefile.am20
1 files changed, 20 insertions, 0 deletions
diff --git a/uxa/Makefile.am b/uxa/Makefile.am
new file mode 100644
index 00000000..641b4146
--- /dev/null
+++ b/uxa/Makefile.am
@@ -0,0 +1,20 @@
+noinst_LTLIBRARIES = libuxa.la
+
+# Override these since UXA doesn't need them and the needed files aren't
+# built (in hw/xfree86/os-support/solaris) until after UXA is built
+SOLARIS_ASM_CFLAGS=""
+
+INCLUDES = \
+ $(XORG_INCS)
+
+AM_CFLAGS = $(WARN_CFLAGS) $(XORG_CFLAGS) $(DIX_CFLAGS)
+
+libuxa_la_SOURCES = \
+ uxa.c \
+ uxa.h \
+ uxa-accel.c \
+ uxa-glyphs.c \
+ uxa-render.c \
+ uxa-priv.h \
+ uxa-unaccel.c
+