summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorMichel Daenzer <michel@daenzer.net>2006-05-21 14:33:34 +0000
committerMichel Daenzer <michel@daenzer.net>2006-05-21 14:33:34 +0000
commitf9db5595fe4d62c54b3a501b2af64b4e2b7035cd (patch)
tree1b1c8bbfd2d9d9d75c498b9e9e9f4983b1f0191e /configure.ac
parent25ba85cab8b3d831da646fef19f01769410fc958 (diff)
Derive ATI_VERSION_{MAJOR,MINOR,PATCH} from package version in order to
hopefully confuse bug triagers a little less.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac9
1 files changed, 9 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 92dc830..3d9abb8 100644
--- a/configure.ac
+++ b/configure.ac
@@ -25,6 +25,15 @@ AC_INIT([xf86-video-ati],
6.6.0,
[https://bugs.freedesktop.org/enter_bug.cgi?product=xorg],
xf86-video-ati)
+AC_DEFINE_UNQUOTED([ATI_VERSION_MAJOR],
+ [$(echo $PACKAGE_VERSION | sed -e 's/^\([[0-9]]\)\.[[0-9]]\.[[0-9]]/\1/')],
+ [Major version])
+AC_DEFINE_UNQUOTED([ATI_VERSION_MINOR],
+ [$(echo $PACKAGE_VERSION | sed -e 's/^[[0-9]]\.\([[0-9]]\)\.[[0-9]]/\1/')],
+ [Minor version])
+AC_DEFINE_UNQUOTED([ATI_VERSION_PATCH],
+ [$(echo $PACKAGE_VERSION | sed -e 's/^[[0-9]]\.[[0-9]]\.\([[0-9]]\)/\1/')],
+ [Patch version])
AC_CONFIG_SRCDIR([Makefile.am])
AM_CONFIG_HEADER([config.h])