summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorColin Hill <colin.james.hill@gmail.com>2011-01-11 17:55:05 -0800
committerColin Hill <colin.james.hill@gmail.com>2011-01-11 17:55:05 -0800
commit8279ab5788671f698956b94dbee7b775ec749a2a (patch)
treec705877067cb6fe1937c2db8eb5a44e237ffef47 /configure.ac
parent0b89f12500679b2056b26dcc771e42cbf1b1a645 (diff)
Added Paulo's source.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac56
1 files changed, 56 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
new file mode 100644
index 0000000..c21f77b
--- /dev/null
+++ b/configure.ac
@@ -0,0 +1,56 @@
+dnl
+dnl Permission is hereby granted, free of charge, to any person obtaining a
+dnl copy of this software and associated documentation files (the "Software"),
+dnl to deal in the Software without restriction, including without limitation
+dnl the rights to use, copy, modify, merge, publish, distribute, sublicense,
+dnl and/or sell copies of the Software, and to permit persons to whom the
+dnl Software is furnished to do so, subject to the following conditions:
+dnl
+dnl The above copyright notice and this permission notice (including the next
+dnl paragraph) shall be included in all copies or substantial portions of the
+dnl Software.
+dnl
+dnl THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
+dnl IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
+dnl FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL
+dnl THE AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER
+dnl LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING
+dnl FROM, OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER
+dnl DEALINGS IN THE SOFTWARE.
+dnl
+dnl Author: Paulo Zanoni <pzanoni@mandriva.com>
+dnl
+
+AC_PREREQ([2.65])
+AC_INIT([xf86-video-nestedv], [0.1.0], [pzanoni@mandriva.com])
+AC_CONFIG_AUX_DIR([build-aux])
+AM_INIT_AUTOMAKE([foreign -Wall -Werror dist-bzip2])
+AM_MAINTAINER_MODE
+AC_PROG_CC
+
+# Require xorg-macros: XORG_DEFAULT_OPTIONS
+m4_ifndef([XORG_MACROS_VERSION],
+ [m4_fatal([must install xorg-macros 1.7 or later before running autoconf/autogen])])
+XORG_MACROS_VERSION(1.7)
+XORG_DEFAULT_OPTIONS
+
+# Initialize libtool
+AC_DISABLE_STATIC
+AC_PROG_LIBTOOL
+
+# Define a configure option for an alternate module directory
+AC_ARG_WITH(xorg-module-dir, [ --with-xorg-module-dir=DIR ],
+ [ moduledir="$withval" ],
+ [ moduledir="$libdir/xorg/modules" ])
+AC_SUBST(moduledir)
+
+PKG_CHECK_MODULES(XORG, [xorg-server])
+PKG_CHECK_MODULES(X11, x11)
+PKG_CHECK_MODULES(XEXT, xext)
+
+DRIVER_NAME=nestedv
+AC_SUBST([DRIVR_NAME])
+
+AC_CONFIG_HEADERS([config.h])
+AC_CONFIG_FILES([Makefile src/Makefile])
+AC_OUTPUT