summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorAaron Plattner <aplattner@nvidia.com>2007-04-20 16:24:15 -0700
committerAaron Plattner <aplattner@nvidia.com>2007-04-20 16:24:15 -0700
commit4ff648c85f8aa90b343b7e2df176c0511b3cdaa5 (patch)
treec599ed02adc4fcb25db4473202a1a933f436e888 /configure.ac
parent48f9a6f94550acea4fce81d2539a6508049c1551 (diff)
Depend on server 1.2 or higher.randr-1.2
Remove support for building with the libc wrapper or without the Drawable XV argument.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac8
1 files changed, 1 insertions, 7 deletions
diff --git a/configure.ac b/configure.ac
index b4fd037..5370beb 100644
--- a/configure.ac
+++ b/configure.ac
@@ -59,14 +59,8 @@ XORG_DRIVER_CHECK_EXT(RENDER, renderproto)
XORG_DRIVER_CHECK_EXT(XV, videoproto)
XORG_DRIVER_CHECK_EXT(DPMSExtension, xextproto)
-# Determine whether XV PutImage takes a DrawablePtr and whether or not to use
-# the libcwrapper.
-PKG_CHECK_EXISTS([xorg-server >= 1.0.99.901],
- [AC_DEFINE(HAVE_XV_DRAWABLE,1,[XV hooks take a DrawablePtr])],
- [AC_DEFINE(USE_LIBC_WRAPPER,1,[Use the libc wrapper])])
-
# Checks for pkg-config packages
-PKG_CHECK_MODULES(XORG, [xorg-server xproto fontsproto $REQUIRED_MODULES])
+PKG_CHECK_MODULES(XORG, [xorg-server >= 1.2 xproto fontsproto $REQUIRED_MODULES])
sdkdir=$(pkg-config --variable=sdkdir xorg-server)
# Checks for libraries.