summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorAaron Plattner <aplattner@nvidia.com>2006-04-27 18:10:37 -0700
committerAaron Plattner <aplattner@nvidia.com>2006-04-27 18:10:37 -0700
commit1a40c4a79b79034d191496726a27af8b0805dba6 (patch)
treee61354b2fcbd5d3de09a5a524220ac376b6663ed /configure.ac
parent425e30d58b7b62fff01fbb58585ee69b2df6fec1 (diff)
Add the libcwrapper back, conditionalized on the server version.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac5
1 files changed, 3 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 8f44298..31637e8 100644
--- a/configure.ac
+++ b/configure.ac
@@ -53,10 +53,11 @@ XORG_DRIVER_CHECK_EXT(RENDER, renderproto)
XORG_DRIVER_CHECK_EXT(XV, videoproto)
XORG_DRIVER_CHECK_EXT(DPMSExtension, xextproto)
-# Determine whether XV PutImage takes a DrawablePtr
+# Determine whether XV PutImage takes a DrawablePtr and whether or not to use
+# the libcwrapper.
PKG_CHECK_EXISTS([xorg-server >= 1.0.99.901],
[AC_DEFINE(HAVE_XV_DRAWABLE,1,[XV hooks take a DrawablePtr])],
- [])
+ [AC_DEFINE(USE_LIBC_WRAPPER,1,[Use the libc wrapper])])
# Checks for pkg-config packages
PKG_CHECK_MODULES(XORG, [xorg-server xproto fontsproto $REQUIRED_MODULES])