summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorIan Romanick <idr@us.ibm.com>2007-08-22 12:38:14 -0700
committerIan Romanick <idr@us.ibm.com>2007-08-22 12:38:14 -0700
commitffc5ba7f0b1cdefdcecf6bd47018b6a4924bfc44 (patch)
treeaef6fd28a77e250c740225ff496f006fb29d0984 /configure.ac
parent68ceead721aeb75b9faed6297407a320a83499e4 (diff)
Merge PCI-rework support and "classic" PCI interface support into one treepci-rework
First pass at merging both trees. So far, this has only been compile tested. I need to dig out a savage card to put in a system for testing, so it may take another hour or two.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac13
1 files changed, 11 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 16c19d0..04a4c3e 100644
--- a/configure.ac
+++ b/configure.ac
@@ -51,6 +51,11 @@ AC_ARG_ENABLE(dri, AC_HELP_STRING([--disable-dri],
[Disable DRI support [[default=auto]]]),
[DRI="$enableval"],
[DRI=auto])
+AC_ARG_ENABLE(pciaccess,
+ AS_HELP_STRING([--enable-pciaccess],
+ [Enable use of libpciaccess (default: disabled)]),
+ [PCIACCESS=$enableval],
+ [PCIACCESS=no])
# Checks for extensions
XORG_DRIVER_CHECK_EXT(RANDR, randrproto)
@@ -95,8 +100,12 @@ if test "$DRI" = yes; then
AC_DEFINE(XF86DRI_DEVEL,1,[Enable developmental DRI driver support])
fi
-PKG_CHECK_MODULES([PCIACCESS], [pciaccess >= 0.5.0])
-XORG_CFLAGS="$XORG_CFLAGS $PCIACCESS_CFLAGS"
+AM_CONDITIONAL(PCIACCESS, [test "x$PCIACCESS" = xyes])
+if test "x$PCIACCESS" = xyes; then
+ AC_DEFINE(PCIACCESS, 1, [Use libpciaccess])
+ PKG_CHECK_MODULES([PCIACCESS], [pciaccess >= 0.7.0])
+ XORG_CFLAGS="$XORG_CFLAGS $PCIACCESS_CFLAGS"
+fi
AC_SUBST([DRI_CFLAGS])
AC_SUBST([XORG_CFLAGS])