summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorGaetan Nadon <memsize@videotron.ca>2012-03-12 14:51:38 -0400
committerJakob Bornecrantz <jakob@vmware.com>2012-03-13 21:37:52 +0100
commit04169f3860e4a7d03485631bee40c05fc45b72c6 (patch)
treefdd3e7689812dd51f3d9bf6909baf7cdfb4f4ce1 /configure.ac
parente6836ff099e5565dea58a53bba9b2df377241ef7 (diff)
config: include saa and vmwgfx subdirs in the tarball
Use AM_CONDITIONAL. Automake knows what to distribute. It needs to be able to navigate down the subdirs to find what needs to be included in the tarball. To test reliably, create a tarball and expand it into a separate directory and build with xatracker. Distcheck will not detect missing code when such code is configured not to build. The content of a tarball *must* always be identical, regardless of the configuration options used or on which platform it was configured. Signed-off-by: Gaetan Nadon <memsize@videotron.ca> Signed-off-by: Jakob Bornecrantz <jakob@vmware.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac18
1 files changed, 6 insertions, 12 deletions
diff --git a/configure.ac b/configure.ac
index cf1491f..af2737a 100644
--- a/configure.ac
+++ b/configure.ac
@@ -120,29 +120,23 @@ DRIVER_NAME=vmware
AC_SUBST([DRIVER_NAME])
AC_MSG_CHECKING([whether to build Kernel Mode Setting and 3D])
-VMWGFX_DIRS=
if test x$BUILD_VMWGFX = xyes; then
AC_MSG_RESULT([yes])
AC_SYS_LARGEFILE
- VMWGFX_DIRS="saa vmwgfx"
- VMWGFX_LIBADD='$(top_builddir)/vmwgfx/libvmwgfx.la'
- AC_CONFIG_FILES([
- saa/Makefile
- vmwgfx/Makefile
- ])
- AC_DEFINE([BUILD_VMWGFX], 1,
- [Building the vmwgfx driver path])
+ AC_DEFINE([BUILD_VMWGFX], 1, [Building the vmwgfx driver path])
else
AC_MSG_RESULT([no])
fi
-AC_SUBST([VMWGFX_DIRS])
-AC_SUBST([VMWGFX_LIBADD])
+AM_CONDITIONAL(BUILD_VMWGFX, test "x$BUILD_VMWGFX" = xyes)
+
AC_CONFIG_FILES([
Makefile
+ man/Makefile
+ saa/Makefile
+ vmwgfx/Makefile
src/Makefile
vmwarectrl/Makefile
- man/Makefile
])
AC_OUTPUT