summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorShelley Gong <shelleygong@vmware.com>2009-04-16 13:28:47 -0700
committerPhilip Langdale <philipl@fido2.homeip.net>2009-04-16 13:28:47 -0700
commite3769142d80953d6da484eb979f5274c8a3abeb3 (patch)
tree3054098a77f32c3578c86a9b8dc2dbadbf90a0fd /configure.ac
parent3c223e8f7b03e2d7f8c31faeeeeb37030c461176 (diff)
Automatically add modelines for the driver's built-in set of modes.
The driver has had a built-in set of modes for a while, but there was nothing adding modelines to back them up, causing initial modes to be rejected at startup with certain Xorg versions. This change adds the actual modelines for sufficiently new versions of the server (>= 1.2), as the necessary calls were only introduced at that time.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac5
1 files changed, 5 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index cb49532..da14e7b 100644
--- a/configure.ac
+++ b/configure.ac
@@ -66,6 +66,11 @@ PKG_CHECK_EXISTS([xorg-server >= 1.0.99.901],
[AC_DEFINE([HAVE_XORG_SERVER_1_0_99_901], 1,
[Has version 1.0.99.901 or greater of the Xserver])])
+PKG_CHECK_EXISTS([xorg-server >= 1.2.0],
+ [AC_DEFINE([HAVE_XORG_SERVER_1_2_0], 1,
+ [Has version 1.2.0 or greater of the Xserver])])
+
+
# Checks for libraries.
# Checks for header files.