summaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorPhilip Langdale <philipl@fido2.homeip.net>2007-02-08 13:42:31 -0800
committerPhilip Langdale <philipl@fido2.homeip.net>2007-02-08 13:42:31 -0800
commitaf8c0596a224ba8436d55c5dd6063fff688c7ad1 (patch)
tree06f205381214ce8bf4f893b48f25f213838fc15b /src/Makefile.am
parent3dc1ebc7c2c76f575b5150f1890ec13f8bd3e8a1 (diff)
Remove XAA 'acceleration'.
We have a lot of stale code to 'accelerate' certain operations through XAA. However, in practice, this acceleration is completely unhelpful because whenever we encounter an unaccelerated action, we have to sync and flush the fifo which kills any performance gain. As such, the virtual hardware doesn't even advertise these acceleration capabilities anymore, so the code is completely unusued. In addition, XAA is on the way out, so there's no point leaving in dead code which will have to go in the fairly near future. The one operation we can meaningfully accelerate is a front-only fill and when we get around to implementing that, we'll use EXA instead.
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am3
1 files changed, 0 insertions, 3 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index b7857b9..97ab86e 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -33,8 +33,6 @@ vmware_drv_la_SOURCES = \
bits2pixels.h \
guest_os.h \
includeCheck.h \
- offscreen_manager.c \
- offscreen_manager.h \
svga_limits.h \
svga_reg.h \
svga_struct.h \
@@ -43,7 +41,6 @@ vmware_drv_la_SOURCES = \
vmware.c \
vmwarecurs.c \
vmware.h \
- vmwarexaa.c \
vmwarectrl.c \
vmwarectrl.h \
vmwarectrlproto.h \