summaryrefslogtreecommitdiff
path: root/vmwarectrl/Makefile.am
diff options
context:
space:
mode:
authorGaetan Nadon <memsize@videotron.ca>2010-08-18 10:57:02 -0400
committerGaetan Nadon <memsize@videotron.ca>2010-08-19 08:18:08 -0400
commit2a72ea7a1b1519451350e0741d145f513124a208 (patch)
tree3d966998657fd0a5360eb8c2eb222e06e9624eb6 /vmwarectrl/Makefile.am
parentf51ca2cb756dcd541a27f0326496f0aadab3f214 (diff)
vmwarectrl: rework standalone package as a subdir of driver
vmwarectrl is a unit test client tool for developers. By default, it is not built unless --enable-vmwarectrl-client is used. Acked-by: Thomas Hellstrom <thellstrom@vmware.com> Signed-off-by: Gaetan Nadon <memsize@videotron.ca>
Diffstat (limited to 'vmwarectrl/Makefile.am')
-rw-r--r--vmwarectrl/Makefile.am12
1 files changed, 8 insertions, 4 deletions
diff --git a/vmwarectrl/Makefile.am b/vmwarectrl/Makefile.am
index 9df209d..ed19384 100644
--- a/vmwarectrl/Makefile.am
+++ b/vmwarectrl/Makefile.am
@@ -1,8 +1,12 @@
-## Process this file with automake to produce Makefile.in
-AUTOMAKE_OPTIONS = dist-bzip2
+if BUILD_VMWARECTRL
bin_PROGRAMS = vmwarectrl
+
+AM_CPPFLAGS = -I$(top_srcdir)/src
+AM_CFLAGS = $(X11_CFLAGS)
+AM_LDFLAGS = $(X11_LIBS)
+
vmwarectrl_SOURCES = vmwarectrl.c libvmwarectrl.c libvmwarectrl.h
-vmwarectrl_CPPFLAGS = @X11_CFLAGS@ -I../src/
-vmwarectrl_LDADD = @X11_LIBS@
+
+endif BUILD_VMWARECTRL