summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorAlan Coopersmith <alan.coopersmith@sun.com>2007-04-05 14:28:06 -0700
committerAlan Coopersmith <alan.coopersmith@sun.com>2007-04-05 14:28:06 -0700
commit2179b2d467d69e45559b8e4f161a904a21f05321 (patch)
tree1c29081ef1bba8766b50b94899273ebb4cd74873 /configure.ac
parent6b361c028b5ad931b61df86fae570f3ef9f41c15 (diff)
Add hooks for checking source code with lint/sparse/etc.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac5
1 files changed, 5 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index fb79a19..2cea81f 100644
--- a/configure.ac
+++ b/configure.ac
@@ -36,6 +36,11 @@ AC_DEFINE(ICE_t, 1, [Xtrans transport type])
# Checks for header files.
AC_HEADER_STDC
+dnl Allow checking code with lint, sparse, etc.
+XORG_WITH_LINT
+XORG_LINT_LIBRARY([ICE])
+LINT_FLAGS="${LINT_FLAGS} ${ICE_CFLAGS} ${XTRANS_CFLAGS}"
+
if test "x$GCC" = "xyes"; then
GCC_WARNINGS="-Wall -Wpointer-arith -Wstrict-prototypes \
-Wmissing-prototypes -Wmissing-declarations \