summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorJames Cloos <cloos@jhcloos.com>2007-12-06 16:38:16 -0500
committerJames Cloos <cloos@jhcloos.com>2007-12-06 16:38:16 -0500
commit2a827d26cfb10dc6b1203b77c0cc91dc838d97a3 (patch)
tree0bd892e49df3d445b1d27ac1f1f102d09403700b /Makefile.am
parent9b7029aba10356badeef134af2de7e26e6ae2ab9 (diff)
Replace static ChangeLog with dist-hook to generate from git log
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am10
1 files changed, 10 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 713eddf..aa2fb39 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -4,3 +4,13 @@ pkgconfigdir = $(libdir)/pkgconfig
pkgconfig_DATA = sm.pc
EXTRA_DIST=sm.pc.in
+
+EXTRA_DIST += ChangeLog
+MAINTAINERCLEANFILES = ChangeLog
+
+.PHONY: ChangeLog
+
+ChangeLog:
+ (GIT_DIR=$(top_srcdir)/.git git-log > .changelog.tmp && mv .changelog.tmp ChangeLog; rm -f .changelog.tmp) || (touch ChangeLog; echo 'git directory not found: installing possibly empty changelog.' >&2)
+
+dist-hook: ChangeLog