summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gmail.com>2011-08-01 23:52:31 -0400
committerMatt Turner <mattst88@gmail.com>2011-08-01 23:52:31 -0400
commit85bdcab66a56ca93a7eee0eadf12a90056dfa41d (patch)
tree908fb38b78c57e5bb0e088a67c73e7cde6ee164f /Makefile.am
parent892b45fdb681a18c7ecaf456457fd7e4c588998d (diff)
Replace Imake with autotools build system.
Partially based on the work of David Leverton <levertond@googlemail.com> Rafał Mużyło <galtgendo@o2.pl> https://bugs.gentoo.org/show_bug.cgi?id=290410 Signed-off-by: Matt Turner <mattst88@gmail.com>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am7
1 files changed, 7 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
new file mode 100644
index 0000000..1d2a450
--- /dev/null
+++ b/Makefile.am
@@ -0,0 +1,7 @@
+SUBDIRS = include src
+
+install-exec-hook:
+ cd $(DESTDIR)$(libdir) && rm -f libXaw3d.@LIBEXT@ && $(LN_S) $(DEFAULT_LIB) libXaw3d.@LIBEXT@
+
+uninstall-local:
+ -rm -f $(DESTDIR)$(libdir)/libXaw3d.@LIBEXT@