summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorRafał Mużyło <galtgendo@o2.pl>2011-08-03 02:28:19 +0200
committerMatt Turner <mattst88@gmail.com>2011-08-03 15:58:50 -0400
commit76c5f905c7178cf76cdf8a5817bb1575d8cdba82 (patch)
tree089777ae1aa893aba0a0a4c48a3ab4c54a9914dc /configure.ac
parent4b7af3dca51bccb86816d7c0e8995ce009f9999e (diff)
Remove unneeded libtool hacks
Signed-off-by: Rafał Mużyło <galtgendo@o2.pl> Signed-off-by: Matt Turner <mattst88@gmail.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac35
1 files changed, 1 insertions, 34 deletions
diff --git a/configure.ac b/configure.ac
index 50e38f7..80931fc 100644
--- a/configure.ac
+++ b/configure.ac
@@ -20,41 +20,8 @@ AM_PROG_CC_C_O
# is in an if statement, and later calls would break if it's skipped.
PKG_PROG_PKG_CONFIG
-#
-# fix libtool to set SONAME to libXaw3d.so.$major
-#
-AC_CONFIG_COMMANDS([libtool_hack], [
- cp -f libtool libtool_
- test -z "$SED" && SED=sed
- $SED '1,/^soname_spec/{
-/^soname_spec/i\
-# X.Org hack to match monolithic Xaw3d SONAME\
-xorglibxawname="libXaw3d"
-/^soname_spec/s/libname/xorglibxawname/
-}' libtool_ > libtool
- rm -f libtool_
-])
-
-# OSX/Win32 rules are different.
-platform_win32=no
-platform_darwin=no
-LIBEXT=so
-case $host_os in
- cygwin*|mingw*)
- LIBEXT=dll.a
- platform_win32=yes
- ;;
- darwin*)
- LIBEXT=dylib
- platform_darwin=yes
- ;;
-esac
-AC_SUBST(LIBEXT)
-AM_CONDITIONAL(PLATFORM_WIN32, test "x$platform_win32" = "xyes")
-AM_CONDITIONAL(PLATFORM_DARWIN, test "x$platform_darwin" = "xyes")
-
# Checks for header files.
-PKG_CHECK_MODULES(X11, [x11, xt, xmu])
+PKG_CHECK_MODULES(X11, [x11 xt xmu])
AC_CHECK_HEADERS([wctype.h wchar.h widec.h])
AC_CONFIG_FILES([Makefile