summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorAlan Coopersmith <alan.coopersmith@sun.com>2006-10-10 13:33:33 -0700
committerAlan Coopersmith <alan.coopersmith@sun.com>2006-10-10 13:33:33 -0700
commitd0e12a97849871b0b2af04bf8d7a3839c54b31a8 (patch)
tree6f54e01dbcad005acf2c27127d798b128ac5cc28 /Makefile.am
parent932965298c244553f303fab3bdf23941cc40bb23 (diff)
Add XORG_WITH_LINT to allow checking code with lint/sparse/etc.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am5
1 files changed, 5 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 3355bdd..0050eb2 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -29,3 +29,8 @@ pkgconfigdir = $(libdir)/pkgconfig
pkgconfig_DATA = xcursor.pc
EXTRA_DIST = xcursor.pc.in autogen.sh
+
+if LINT
+lint:
+ (cd src && $(MAKE) $(MFLAGS) lint)
+endif LINT