summaryrefslogtreecommitdiff
path: root/man/Makefile.am
diff options
context:
space:
mode:
authorAlan Coopersmith <alan.coopersmith@sun.com>2007-08-21 19:33:00 -0700
committerAlan Coopersmith <alan.coopersmith@sun.com>2007-08-21 19:33:00 -0700
commita9ccf1bd91ad6e06f7b7116efe836c365b68645b (patch)
treedd3ba574f24c6afb94294c7c9ba7fc22056c2828 /man/Makefile.am
parent110131bd40d0fc042f4a81922372307a1582b591 (diff)
Use cursorpath found by configure in man page
Diffstat (limited to 'man/Makefile.am')
-rw-r--r--man/Makefile.am11
1 files changed, 10 insertions, 1 deletions
diff --git a/man/Makefile.am b/man/Makefile.am
index 725a676..e8ddd70 100644
--- a/man/Makefile.am
+++ b/man/Makefile.am
@@ -13,6 +13,15 @@ SUFFIXES = .$(LIB_MAN_SUFFIX) .man
# Strings to replace in man pages
XORGRELSTRING = @PACKAGE_STRING@
+MAN_SUBSTS = \
+ -e 's|__xorgversion__|"$(XORGRELSTRING)"|' \
+ -e 's|__XCURSORPATH__|$(XCURSORPATH_LIST)|g' \
+ -e 's|__appmansuffix__|$(APP_MAN_SUFFIX)|g' \
+ -e 's|__libmansuffix__|$(LIB_MAN_SUFFIX)|g' \
+ -e 's|__adminmansuffix__|$(ADMIN_MAN_SUFFIX)|g' \
+ -e 's|__miscmansuffix__|$(MISC_MAN_SUFFIX)|g' \
+ -e 's|__filemansuffix__|$(FILE_MAN_SUFFIX)|g'
+
.man.$(LIB_MAN_SUFFIX):
-rm -f $@
- sed 's/__xorgversion__/"$(XORGRELSTRING)"/; s/__LIB_MAN_SUFFIX__/$(LIB_MAN_SUFFIX)/; s%__prefix__%$(prefix)%g; s%__ICONDIR__%$(ICONDIR)%g' < $< > $@
+ sed $(MAN_SUBSTS) < $< > $@