summaryrefslogtreecommitdiff
path: root/man/Makefile.am
diff options
context:
space:
mode:
authorGaetan Nadon <memsize@videotron.ca>2010-08-16 19:17:21 -0400
committerGaetan Nadon <memsize@videotron.ca>2010-08-16 19:23:57 -0400
commitb18568dd5b5a11ae49cad66a54ec50465c6ffa77 (patch)
treeffc3be64798a495b055fc8076e7df1b2614b41fe /man/Makefile.am
parent68d830bcf67632b474c8996b6a2c9bcde8e27f97 (diff)
man: store shadow man pages in git rather than generating them
Simplify the build process and the makefile. Local fix in CVS for bug 5628 is not required as the problem has been fixed in util-macros d9062e4077ebfd0985baf8418f3d0f111b9ddbba Signed-off-by: Gaetan Nadon <memsize@videotron.ca>
Diffstat (limited to 'man/Makefile.am')
-rw-r--r--man/Makefile.am23
1 files changed, 4 insertions, 19 deletions
diff --git a/man/Makefile.am b/man/Makefile.am
index b306de2..c7d55fe 100644
--- a/man/Makefile.am
+++ b/man/Makefile.am
@@ -1,31 +1,21 @@
libmandir = $(LIB_MAN_DIR)
-libman_PRE = Xcursor.man
-libman_DATA = $(libman_PRE:man=@LIB_MAN_SUFFIX@)
+libman_PRE = Xcursor.man \
+ $(Xcursor_shadows:=.man)
-all-local: $(libman_DATA)
+libman_DATA = $(libman_PRE:man=@LIB_MAN_SUFFIX@)
EXTRA_DIST = $(libman_PRE)
CLEANFILES = $(libman_DATA)
SUFFIXES = .$(LIB_MAN_SUFFIX) .man
-# Strings to replace in man pages
-XORGRELSTRING = @PACKAGE_STRING@
-
# String replacements in MAN_SUBSTS now come from xorg-macros.m4 via configure
-MAN_SUBSTS = -e 's|__XCURSORPATH__|$(XCURSORPATH_LIST)|g'
+MAN_SUBSTS += -e 's|__XCURSORPATH__|$(XCURSORPATH_LIST)|g'
.man.$(LIB_MAN_SUFFIX):
$(AM_V_GEN)$(SED) $(MAN_SUBSTS) < $< > $@
-# Generate man page shadow files
-
-LIB_MAN_DIR_SUFFIX = $(LIB_MAN_DIR:@mandir@/man%=%)
-libman_DATA += $(Xcursor_shadows:=.@LIB_MAN_SUFFIX@)
-BUILT_SOURCES = shadows.DONE
-CLEANFILES += shadows.DONE
-
Xcursor_shadows = \
XcursorImageCreate \
XcursorImageDestroy \
@@ -59,8 +49,3 @@ Xcursor_shadows = \
XcursorSetTheme \
XcursorGetTheme
-shadows.DONE:
- -rm -f $(Xcursor_shadows:=.@LIB_MAN_SUFFIX@)
- (for i in $(Xcursor_shadows:=.@LIB_MAN_SUFFIX@) ; do \
- echo .so man$(LIB_MAN_DIR_SUFFIX)/Xcursor.$(LIB_MAN_SUFFIX) > $$i; \
- done)